The brief increases in latency affecting some redirects have been resolved.
Posted Aug 15, 2025 - 10:06 MDT
Monitoring
Our Incident Response Team (IRT) has deployed a fix for the brief increases in latency.
We’re monitoring to ensure normal performance continues.
Next update within 24 hours.
Posted Aug 14, 2025 - 09:24 MDT
Identified
We are deploying changes to improve brief periods of intermittent latency.
Next update within 24 hours.
Posted Aug 13, 2025 - 16:02 MDT
Update
Users may be experiencing brief increases in latency on some redirects. Our IRT continues to investigate the issue.
Next update will be provided within 24 hours.
Posted Aug 12, 2025 - 21:57 MDT
Update
Our Incident Response Team (IRT) has deployed a fix that has resolved the degraded performance. We are continuing to investigate the root cause.
Next update will be provided within 24 hours.
Posted Aug 12, 2025 - 11:03 MDT
Update
Our Incident Response Team (IRT) is continuing to investigate this issue.
You can expect to receive an update within the next 24 hours.
Posted Aug 11, 2025 - 16:19 MDT
Investigating
We are investigating brief increases in latency that may be affecting some redirects.
Posted Aug 11, 2025 - 12:48 MDT
This incident affected: Redirection Services (Global Edge (HTTP traffic), Global Edge (HTTPS traffic), US West Edge (HTTP traffic), US West Edge (HTTPS traffic)).