The scheduled database maintenance has been completed.
Posted Jun 28, 2025 - 14:06 MDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 28, 2025 - 09:00 MDT
Scheduled
We’re scheduling dashboard and API system maintenance on Saturday, June 28, for the below times: - 11:00am – 7:00pm Eastern Time (ET) - 5:00pm – 1:00am Central European Summer Time (CEST) - 1:00am – 9:00am Australian Eastern Standard Time (AEST) — Sunday, June 29
We’ll bring systems back online as soon as possible.
Here’s what to expect during the maintenance: - Redirects will continue to function normally – traffic will be routed without interruption - The dashboard and API will be temporarily unavailable, which means you won’t be able to: - Create, update or remove redirects - View analytics - Modify your subscription
Posted Jun 23, 2025 - 13:03 MDT
This scheduled maintenance affected: Dashboard, API and urllo Sites & Services (Background Workers, Analytics, Service Emails, Credit Card Management, Subscription Management).