Tail latencies on redirects have returned to normal levels.
Posted Aug 27, 2025 - 11:05 MDT
Update
We are continuing to monitor for any further issues.
Next update within the next 24 hours.
Posted Aug 26, 2025 - 12:24 MDT
Monitoring
Our Incident Response Team (IRT) has deployed a fix to resolve the increased latency on redirects.
We’re monitoring to ensure normal performance continues.
Next update within the next 24 hours.
Posted Aug 25, 2025 - 18:11 MDT
Investigating
Our Incident Response Team (IRT) is investigating a potential service disruption. Users may be experiencing increased latency on redirects.
We will post additional updates as new information is available.
Posted Aug 25, 2025 - 16:24 MDT
This incident affected: Redirection Services (Global Edge (HTTP traffic), Global Edge (HTTPS traffic), US West Edge (HTTP traffic), US West Edge (HTTPS traffic)).