Investigating increased latency on redirects.

Incident Report for urllo

Resolved

Increased latency on redirects has been resolved.
Posted Aug 29, 2025 - 10:10 MDT

Identified

We’ve identified the source of the elevated tail latencies and are working to resolve the issue.

Next update within 24 hours.
Posted Aug 28, 2025 - 12:21 MDT

Investigating

Our Incident Response Team (IRT) is investigating brief increases in latency that may be affecting some redirects.

Next update within 24 hours.
Posted Aug 28, 2025 - 12:04 MDT
This incident affected: Redirection Services (Global Edge (HTTP traffic), Global Edge (HTTPS traffic), US West Edge (HTTP traffic), US West Edge (HTTPS traffic)).